How to check if your Go app supports TLS 1.2

As you may have already noticed, many API requires everyone to use at least TLS 1.2 to meet their data security standard.

How would you check the go version you are using or your Golang App supports TLS 1.2 or not?

Well, the good news is

All version of Go supports TLS 1.2 and you don’t need to worry.

Even though if you would need to verify the same you can do by sending a request at “https://www.howsmyssl.com/a/check” and checking TLS version in its response.

golang tls version check

References:

  • https://www.calazan.com/how-to-check-if-your-python-app-supports-tls-12/
  • http://help.friendbuy.com/service-announcements/how-do-i-test-my-api-integration-to-verify-support-for-tls-1112

Leave a Reply